The Main Menus

Submitted by Ben on Fri, 09/21/2007 - 10:18

Welcome to Ardour's main window. Looks good, doesn't it? Even if you have little to no experience with recording, you'll notice some familiar features right off the bat. Along the top edge of the window is the menu bar.



Figure 2: Ardour's editor window (click for full size).


The Session Menu

The first item in the menu bar is the Session menu, which is analogous to the file menu in most other programs. Some notable differences in the session menu are snapshot, Add Track/Bus and Add Existing Audio. Snapshot will save a backup of your session; add track/bus and add existing audio are self-explanatory.

The Transport Menu

The Transport menu contains a variety of controls for the system's transport. You can move the playhead, enable recording, start and stop playback. It would be well worth your effort to learn some of the keyboard shortcuts in this menu. For example, Shift+R enables recording, and ctrl+space stops and forgets the last capture.

The Edit Menu

The Edit menu contains typical editing operations, as well as controls to position the edit cursor (more on that later) and work with regions. Take a look at the keymouse operations, they can save you time when using Ardour.

The View Menu

The View menu has items that control the layout and positioning of elements in Ardour's editor window. At the bottom of the menu you'll notice the "Show editor mixer" option. Click on that option now and notice the editor mixer strip on the left side of the window. This is a one-strip embedded mixer window that stays attached to the editor window and shows only the mixer strip for the currently selected track. We'll discuss the details of mixer strips more in the next section.

The JACK Menu

The JACK menu is next, and it allows you to disconnect or reconnect from the JACK server. This can be useful if you need to alter your JACK server settings, or if the JACK server crashes. There's another option in this menu called latency, which is the same thing as buffer size in Jack Control's setup window.

The Windows Menu

The Windows menu contains links to all of Ardour's windows. You can also maximize editor space from here, or by pressing F11. This has the effect of hiding the controls and lists, allowing you to focus on the canvas. The Options Editor is where you should go to set the outputs for the click and audition tracks, among many other things. The Track/Bus Inspector lets you examine all the ins and outs (not to mention redirects) of a track or bus in one window. You may like to enable the big clock as well, to get a clearer view of the session's timing.

The Options Menu

The Options menu contains various options which go beyond the scope of this tutorial. Consult the Ardour manual for more information on each one.

The Help Menu

Lastly, the help menu provides a link to the about box. When the Ardour manual is complete, it may be referenced here as well.

To the right of the menus are various numerical indicators showing (from left to right) your sample rate, latency, playback and capture buffer sizes, processor load, amount of audio recorded for this session and time of day.