Wine 1.1.17 no alsa drivers present, only NAS = no sound

  • amadeus
Posted: Fri, 03/27/2009 - 22:14
Hello all, I have 64studio Beta 3 with hardy installed, and I have no sound drivers in my winecfg, All that is present in the audio drivers of winecfg is NAS, I have not been able to fix this. What could be missing, I have the winealsa driver in /usr/lib/wine but I don't know what is going on, and due to this I have no sound with wine. And I installed wine with apt-get install wine, and it bought me up to the newest version, the other version previously to this version did the same thing, no alsa drivers and no oss and no Jack. Thanks

Install wine-dev from the wine-hq repo

  • Pablo
  • 07/11/07
  • Sun, 03/29/2009 - 10:26
Hi Amadeus, these are the wine libraries 64studio installs by default. It's the same case as mine. If you follow my aforesaid post and install a compatible wine-dev you'll have a winecfg that will see ALSA. Cheers! Pablo

Install wine-dev

  • amadeus
  • 03/14/09
  • Sun, 03/29/2009 - 22:39
Thanks Pablo, I will do just that, install the wine-dev pkgs. I appreciate your time with this. I should be marking this one solved very soon.

Wine 1.1.17 no alsa drivers present, only NAS =no sound (SOLVED)

  • amadeus
  • 03/14/09
  • Mon, 03/30/2009 - 08:03
Thanks Pablo I followed your link http://www.64studio.com/node/1023 (4th post) and it told me exact what to do, all works now. I have alsa and Jack drivers working.

Wine

  • Pablo
  • 07/11/07
  • Sat, 03/28/2009 - 02:56
Hi Amadeus, Can you give the output of: dpkg -l | grep wine as you have it right now with this issue, please. Mind you, in my beta install I didn't check if there was ALSA in winecfg. However, I went directly to install wine-dev from the wine-hq repository and force wine version to the one from wine-hq. Then winecfg is OK with the audio drivers. See details at: http://www.64studio.com/node/1023 (4th post) Cheers! Pablo.

Wine 1.1.17 no alsa drivers present, only NAS = no sound

  • amadeus
  • 03/14/09
  • Sat, 03/28/2009 - 17:49
Thanks Pablo for your reply, here is my output from dpkg -l | wine ii libwine 1.1.17-0.64studio2~hardy1 Windows API implementation - library ii libwine-cms 1.1.17-0.64studio2~hardy1 Windows API implementation - color managemen ii libwine-gl 1.1.17-0.64studio2~hardy1 Windows API implementation - OpenGL module ii libwine-gphoto2 1.1.17-0.64studio2~hardy1 Windows API implementation - camera module ii libwine-ldap 1.1.17-0.64studio2~hardy1 Windows API implementation - LDAP module ii libwine-nas 1.1.17-0.64studio2~hardy1 Windows API implementation - NAS sound modul ii libwine-print 1.1.17-0.64studio2~hardy1 Windows API implementation - printing module ii libwine-sane 1.1.17-0.64studio2~hardy1 Windows API implementation - scanner module ii wine 1.1.17-0.64studio2~hardy1 Windows API implementation - standard suite ii wine-bin 1.1.17-0.64studio2~hardy1 Windows API implementation - binary loader ii wine-utils 1.1.17-0.64studio2~hardy1 Windows API implementation - utilities rc wineasio 0.7.4+pljones2-3~hardy1 ASIO to JACK bridge