getting headers & source for multimedia kernel

  • pleasebeus
Posted: Sat, 06/13/2009 - 11:45
I've installed 64Studio after dumping Ubuntu Studio 9.04 having had a bad time getting nVidia drivers working. I'm now trying this with 64Studio. To install a legacy driver (NVIDIA-Linux-x86-96.43.05-pkg1.run) for my card the nVidia installation needs to compile a kernel interface. How do I get the kernel source available to this installer for the multimedia 2.6.29-1multimedia-686 kernel? Or, better, has anyone successfully installed an nvidia card like mine and can walk me through? I've gone through various faq's and ubuntu tutorials without success and am now starting again with a fresh install. Many thanks!

Dave, thanks for your help.

  • pleasebeus
  • 06/12/09
  • Mon, 06/15/2009 - 15:45
Dave, thanks for your help. The nVidia guide is great; at least I know what driver to install when I'm able to (it's the 96.x). Should be a breeze once their installer is working with the latest kernel. I gave installing 2.6.26 a shot but failed miserably - I couldn't find a reliable guide to install an older kernel & it failed on dependencies etc. Any pointers? I'd want a real time kernel. Ta AMD Athlon 2400+, 3GB, nVidia GeForce4 MX 440-8X, twin monitors, M-Audio 1010LT

64studio 2.1 nvidia

  • skullnotions
  • 09/29/07
  • Sun, 06/14/2009 - 13:32
Yes the nvidia drivers are fine on 2.1, or you could look at installing the 2.6.26 kernel which is very good. Do a search on the forum and you'll find help with your nvidia card. The next beta(4) shouldn't be too long now. See: nVidia FastWrite and Side Band Address post here: Cheers! Dave.

I see. Is the final release

  • pleasebeus
  • 06/12/09
  • Sat, 06/13/2009 - 17:42
I see. Is the final release expected Jun/Jul (can live without 2 monitors for a while if so) or otherwise will I be able to install the binary driver on 2.1? ta AMD Athlon 2400+, 3GB, nVidia GeForce4 MX 440-8X, twin monitors, M-Audio 1010LT

nVidia binary driver

  • skullnotions
  • 09/29/07
  • Sat, 06/13/2009 - 14:25
Hi, The nVidia binary driver won't install on the 2.6.29-1-multimedia kernel as the headers & source are broken. The only way it can be done at present is by rebuilding the kernel yourself. This should be fixed for the final release. Cheers! Dave.