64 studio 3.0 beta3 and jack-dev

  • weng
Posted: Wed, 06/17/2009 - 08:02
Hi, Two days ago i decided to install the 3.0 beta3 after screwing up my lenny in an attempt to morph it to 64studio. I installed the 2.6.26 kernel 'cos it installed the 2.6.29-multimedia kernel by default and this one made jack complain about not being able to load the ieee drivers. Sofar the 2.6.26 is fine (I'm able to have sub-ms latency with my firepod - with some xruns though ;) , but a stable config around 2ms latency). So first, THANK YOU GUYS who spend so much time improving the set of packages and testing things. This really makes 64 studio worth it, and I am truly amazed by the performances of my athlonXP64/2Gb ram with this distro. Second, I'd like to be able to compile... Compile the upcoming Ardour3 (and the 2.8.1 when it's out there), compile seq24 0.9, and other Jackd-related stuff... But the problem is, whenever i try to install jack-dev packages, or uninstall, synaptic wants to take off a bunch of packages (like 64studio and other related packages) which i don't feel at all to remove. I bet no-one would ;). Is there another way of getting the jack headers, or should I just compile jack and install it over the packages provided by the distro ? Thanks ahead.

My Pleasure

  • Quentin Harley
  • 05/24/07
  • Tue, 07/14/2009 - 17:15
I have to spread the love... Hard to know there are people out there suffering while everything is looking up for my system. Cheers, Quentin

Thanks Quentin

  • weng
  • 06/16/09
  • Tue, 07/14/2009 - 11:39
Hi Quentin, Thanks for the tip of your repository. I had it already in my sources.list but didn't enable it and instead stayed on the "regular" 64studio3 repo. It's all ok now, indeed quick support !! Apps compiling flawlessly. Thanks again.

Problems

  • Quentin Harley
  • 05/24/07
  • Fri, 07/10/2009 - 16:22
Hi Weng, The repositories are broken, and the one guy that can fix them at them moment is temporarily swamped... Have you tried my personal repository? deb http://apt.harleystudio.co.za/ hardy main

Anyone ?

  • weng
  • 06/16/09
  • Fri, 07/10/2009 - 10:12
As the title says... I'm stuck, and aren't the other beta3 testers in the same situation ? If not, can you tell me which version of jack you are running ? Thanks, Gwen

Follow-up

  • weng
  • 06/16/09
  • Wed, 07/08/2009 - 11:57
Hi all, Got home, to find my PC was blown for some unknown reason while the UPS-backup was off !! Sooo, after replacing dead Mb and Ps, I tried to install the Package Icemouse linked to. I get these dependency errors: libjack-dev dépend de libjack0 (= 1.9.2-0.64studio2~hardy1) ; but : libjack0 installed version is 1.8+0.71-0.64studio2~hardy1. libjack-dev dépend de libjackserver-bin (= 1.9.2-0.64studio2~hardy1) ; but : libjackserver-bin installed version is 1.8+0.71-0.64studio2~hardy1. libjack-dev dépend de libjackserver0 (= 1.9.2-0.64studio2~hardy1) ; but : libjackserver0 installed version is 1.8+0.71-0.64studio2~hardy1. (Sorry if the translation is incorrect) I can't find 1.9 in the repos though. This is really weird 'cos it seems that installing/uninstalling any jack package showing up in synaptic will break my system. Any hint greatly appreciated.

Yeah, rock on !

  • weng
  • 06/16/09
  • Mon, 06/29/2009 - 19:39
That's cool, I'm home in two weeks (edit: two days !!). I'll let ya know how it goes. Thanks a lot.

libjack-dev_1.9.2-0.64studio2~hardy1_amd64.deb

  • Icemouse
  • 08/04/07
  • Sat, 06/20/2009 - 18:45
The package is available at Hth, Ralf

Bugs

  • Quentin Harley
  • 05/24/07
  • Sat, 06/20/2009 - 09:48
Hi Weng, It seems this is directly related to a bug in our backporter interface on the main package server. For some reason it reports packages being backported, but never creates the packages themselves. This is indeed a high priority and will be solved as soon as possible. Cheers, Quentin

Thanks for info

  • weng
  • 06/16/09
  • Thu, 06/18/2009 - 09:57
Ah, ok, thanks for the information, Pablo. I'm away for two weeks so i'll not be able to try anything for a while. I hope too they will look at it asap. Cheers.

There is an open ticket on this

  • Pablo
  • 07/11/07
  • Wed, 06/17/2009 - 17:55
Hi Weng, If I am not wrong, there is an open ticket with this problem... When I installed 64studio beta, jackd was version 1.9.2 and I had no problem on installing the libjack-dev packages from synaptic. However, right now all the jack related packages, including the libjack-dev's with this version number, are out of the 64studio ("hardy-backports") repo. Probably you have jackd 1.9.2 from the DVD but there is only an older version of the development packages from the hardy repo... I know this is not a solution, just fyi. I hope maintainers look at this asap. Cheers! Pablo.