howto upgrade to kino 1.1.1

  • cyrille
Posted: Wed, 08/08/2007 - 11:36
64 studio has kino 0.9.2 now 1.1.1 is out, how to upgrade? tried to compile from source but I get error: checking how to run the C++ preprocessor... /lib/cpp configure: error: C++ preprocessor "/lib/cpp" fails sanity check thank you cyrille

-dev

  • Quentin Harley
  • 05/24/07
  • Mon, 08/13/2007 - 20:48
Hey Cyrille, You need to install the *-dev versions of the libraries. Look down the long list in synaptic and tick all the development packages for the ones that are installed. Most notably, select
  • libasound2-dev : ALSA
  • xorg dev
Keep going until you have yes for all the major dependencies. Should go then! Cheers

configure

  • cyrille
  • 07/14/07
  • Thu, 08/09/2007 - 10:12
thank you Daniel I went a bit further now it hangs on: checking for ALSA... no configure: WARNING: No package 'alsa' found checking for X... no checking X11/Xlib.h usability... no checking X11/Xlib.h presence... no checking for X11/Xlib.h... no configure: error: Xlib.h or Xutil.h not found install xdevel but I cannot find these files in the synaptic any Ideas?

Try g++

  • Daniel
  • 05/22/07
  • Wed, 08/08/2007 - 15:42
Hi Cyrille, I think you are missing some development packages, such as g++: http://packages.debian.org/stable/devel/g++ I suggest enabling the Etch source in /etc/apt/sources.list.d/64studio.list Then run (as root): apt-get update apt-get install g++ You will find every development package you could ever need in Debian. Cheers!