Two JACK/ALSA questions.

  • Heartarchy
Posted: Sat, 06/27/2009 - 13:37
First, I guess I should say how my studio is set up. I have a Roland VS-1680 DAW which records at 44100 and 24bit going into my SoundBlaster Extigy (24bit card) which then, using JACK, I connect to Ardour and re-record using midi sync. I'm basically confused/curious on two points. One, do JACKs messages saying "ALSA: final selected sample format for playback: 16bit little-endian" imply that my audio is actually being recorded in 16bit? And two, if that happens to be true, is there a way I can keep the audio 24bit? I could be way off, I'm not sure. I couldn't really find much on the topic given a brief google. Thanks in advance, -Troy

Creative

  • Quentin Harley
  • 05/24/07
  • Wed, 07/01/2009 - 16:03
The Creative name seems to apply only to their sales department ;-) I have a dud creative card as well that I bought long before building my new studio system. Works for You-tube. Cheers, Quentin

It turns out Creative was

  • Heartarchy
  • 09/17/08
  • Wed, 07/01/2009 - 14:28
It turns out Creative was lying in some regards. http://www.mail-archive.com/alsa-devel@lists.sourceforge.net/msg05552.html Sure, it has the capability... but apparently it can't send 24bit through the usb. However, a firmware/driver update (for Windows) from the Creative site says: "Sample Rate Conversion engine has been improved to allow playback of 24bit/96KHz files through the 16bit/48KHz engine." Which gives me hope that there's an ever-so-slight possibility. I'm going to do some more seaching and see what I can come up with. -Troy

Thanks, as always, for the

  • Heartarchy
  • 09/17/08
  • Sat, 06/27/2009 - 19:03
Thanks, as always, for the ridiculously fast reply. I mainly had it on 88200 because it's twice of 44100, as I've heard that has better tendencies when downsampling for CD quality, and to cut my latencies in half. When I configure JACK with 44100, 3 periods and 64 frames (only works with 3/64+) it still says it's in 16bit. A few things I forgot to mention earlier, I'm running a 2.6.29.5-rt22 on a lenny-turned-64studio box with rtirq. Alsa-base and linux-sound-base are 1.0.20 from jaunty repos. Any other ideas on what could be causing it? -Troy

Sent.

  • Heartarchy
  • 09/17/08
  • Sat, 06/27/2009 - 16:44
Sent.

Log

  • Quentin Harley
  • 05/24/07
  • Sat, 06/27/2009 - 15:22
Hi Troy, Do you mind sending me the ful contents of the jack message window? Send to quentin AT thenaneofthissite dot com. Cheers, Quentin