Ardour 2.8.2

  • Quentin Harley
Posted: Sat, 07/25/2009 - 22:45
ardour 2.8.2 is in my personal repository for amd64 and i386 Install using dpkg... This did not work... New info! Ardour 2.8.2 has been included in the official ubuntu hardy universe repository, and is available for install via Synaptic. PS: don't forget to visit and make a donation. Cheers, Q

built from source

  • kaimerra
  • 11/14/08
  • Thu, 09/03/2009 - 04:42
I built ardour 2.8.2 from source tonight with LV2 support. I also used the FREEDESKTOP=1 and FREESOUND=1 flags for scons. I didn't have much trouble getting the depencies through apt-get. I did hit an error during install about no theme index. I ran 'gtk-update-icon-cache --ignore-theme-index /usr/local/share/icons/hicolor' like it suggested and did the install again and it worked! Not sure if that is a scons, gtk or 64 studio bug. The LV2 plugins sound great, tough it did crash once on a CALF plugin because of some casting error. Freesound import doesn't work, but from searching the forums at ardour, that appears to be broken on freesound's end. ~~~ Login was cool, connection = 1 Logged in. ~~~ I thought the freedesktop option would have made my ardour session files have icons and be able to open them directly, but it doesn't appear so. Maybe a logout is required? Here is my output from ardour starting up, hopefully there are things that might be useful to the dev crew. ~~~ (ardour-2.8.2:20474): Gtk-CRITICAL **: gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed (ardour-2.8.2:20474): Gtk-CRITICAL **: gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed (ardour-2.8.2:20474): GLib-GObject-WARNING **: invalid cast from `gtkmm__GtkHBox' to `CalfVUMeter446290' Segmentation fault brian@64studio:~$ ardour2 WARNING: Your system has a limit for maximum amount of locked memory! This might cause Ardour to run out of memory before your system runs out of memory. You can view the memory limit with 'ulimit -l', and it is normally controlled by /etc/security/limits.conf Ardour/GTK 2.8.2 (built using 5396 and GCC version 4.2.4 (Ubuntu 4.2.4-1ubuntu4)) Copyright (C) 1999-2008 Paul Davis Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker Ardour comes with ABSOLUTELY NO WARRANTY not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. This is free software, and you are welcome to redistribute it under certain conditions; see the source for copying conditions. theme_init() called from internal clearlooks engine /usr/share/themes/Clearlooks/gtk-2.0/gtkrc:67: error: unexpected identifier `colorize_scrollbar', expected character `}' loading default ui configuration file /usr/local/etc/ardour2/ardour2_ui_default.conf loading user ui configuration file /home/brian/.ardour2/ardour2_ui.conf Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc theme_init() called from internal clearlooks engine ardour: [INFO]: Ardour will be limited to 1024 open files loading system configuration file /usr/local/etc/ardour2/ardour_system.rc loading user configuration file /home/brian/.ardour2/ardour.rc ardour: [INFO]: Using SSE optimized routines Warning: Unable to create "trees" RDF storage. Performance can be improved by upgrading librdf. ardour: [INFO]: looking for control protocols in /home/brian/.ardour2/surfaces/:/usr/local/lib/ardour2/surfaces/ powermate: Opening of powermate failed - No such file or directory ardour: [INFO]: Control protocol powermate not usable ardour: [INFO]: Control surface protocol discovered: "Mackie" ardour: [INFO]: Control surface protocol discovered: "Generic MIDI" loading bindings from /usr/local/etc/ardour2/mnemonic-us.bindings Loading session /home/brian/audio-projects/Punktuation using snapshot Punktuation (1) Loading history from '/home/brian/audio-projects/Punktuation/Punktuation.history'. Found UI http://invadarecords.com/plugins/lv2/tube/mono at index 0 in: /usr/lib/lv2/invada.lv2/inv_tube_gui.so Found UI http://invadarecords.com/plugins/lv2/erreverb/sum at index 0 in: /usr/lib/lv2/invada.lv2/inv_erreverb_gui.so brian@64studio:~$ ardour2 WARNING: Your system has a limit for maximum amount of locked memory! This might cause Ardour to run out of memory before your system runs out of memory. You can view the memory limit with 'ulimit -l', and it is normally controlled by /etc/security/limits.conf Ardour/GTK 2.8.2 (built using 5396 and GCC version 4.2.4 (Ubuntu 4.2.4-1ubuntu4)) Copyright (C) 1999-2008 Paul Davis Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker Ardour comes with ABSOLUTELY NO WARRANTY not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. This is free software, and you are welcome to redistribute it under certain conditions; see the source for copying conditions. theme_init() called from internal clearlooks engine /usr/share/themes/Clearlooks/gtk-2.0/gtkrc:67: error: unexpected identifier `colorize_scrollbar', expected character `}' loading default ui configuration file /usr/local/etc/ardour2/ardour2_ui_default.conf loading user ui configuration file /home/brian/.ardour2/ardour2_ui.conf Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc theme_init() called from internal clearlooks engine ardour: [INFO]: Ardour will be limited to 1024 open files loading system configuration file /usr/local/etc/ardour2/ardour_system.rc loading user configuration file /home/brian/.ardour2/ardour.rc ardour: [INFO]: Using SSE optimized routines ardour: [ERROR]: unknown favorite plugin type "http://plugin.org.uk/swh-plugins/vynil" - ignored ardour: [ERROR]: unknown favorite plugin type "http://invadarecords.com/plugins/lv2/compressor/mono" - ignored Warning: Unable to create "trees" RDF storage. Performance can be improved by upgrading librdf. ardour: [INFO]: looking for control protocols in /home/brian/.ardour2/surfaces/:/usr/local/lib/ardour2/surfaces/ powermate: Opening of powermate failed - No such file or directory ardour: [INFO]: Control protocol powermate not usable ardour: [INFO]: Control surface protocol discovered: "Mackie" ardour: [INFO]: Control surface protocol discovered: "Generic MIDI" ~~~

Allthough, just FOI ...

  • weng
  • 06/16/09
  • Fri, 07/31/2009 - 09:48
A little quote from Ardour's 2.8.2 release article on Tue, 2009-07-21: "[...] Linux users may choose to wait for 2.8.3 in a couple of weeks which will contain a dozen or so other bug fixes. [...]" That sounds great !

2.8.2 is here

  • Quentin Harley
  • 05/24/07
  • Wed, 07/29/2009 - 06:36
Ardour 2.8.2 has been included in the official ubuntu hardy universe repository, and is available for install via Synaptic. PS: don't forget to visit and make a donation. Cheers, Q

Fixed...

  • Quentin Harley
  • 05/24/07
  • Sun, 07/26/2009 - 06:45
Ardour broke the repository... You can get the files here and install via dpkg.

it breaks synaptic: E:

  • capoeira
  • 05/01/09
  • Sun, 07/26/2009 - 01:53
it breaks synaptic: E: Problem parsing dependency Depends E: Um erro ocorreu processando ardour (NovaVersão1) E: Problem with MergeList /var/lib/apt/lists/apt.harleystudio.co.za_dists_hardy_main_binary-i386_Packages E: A lista de pacotes ou o arquivo de status não puderam ser analisados ou abertos. E: _cache->open() failed, please report.