Guitarix from source on 3.0 beta 3

  • kaimerra
Posted: Wed, 08/26/2009 - 03:07
I would like to build the latest version of guitarix from source, but it requires GTK+ 2.14 or later. So I went to compile that and it requires libc6 that isn't available for hardy or in hardy backports. I am wondering what the safe way is do do this before I gett too far down the dependency tree.

Tree Progress

  • kaimerra
  • 11/14/08
  • Thu, 08/27/2009 - 03:30
I tried installing needed packages from intrepid, but ran into a wall. My steps were as follows: Installed findutils_4.4.0-2ubuntu3_i386.deb Installed libgnome2-perl 1.040-1 Installed libc6_2.8 from 64Studio repo Installed libgcrypt11_1.4.1-1ubuntu1_i386.deb Installed libgnutls26_2.4.1-1ubuntu0.4_i386.deb Installed libcups2_1.3.9-2ubuntu9.2_i386.deb libcups2 started complaining because it replaces libcupsys2 and a bunch of stuff depends on that. I am not sure where to go from here. My error output is below. ~~~~ brian@64studio:~/Desktop$ sudo dpkg -i libcups2_1.3.9-2ubuntu9.2_i386.deb dpkg: considering removing libcupsys2 in favour of libcups2 ... dpkg: no, cannot proceed with removal of libcupsys2 (--auto-deconfigure will help): libcupsimage2 depends on libcupsys2 (>= 1.3.4) libcupsys2 is to be removed. dpkg: regarding libcups2_1.3.9-2ubuntu9.2_i386.deb containing libcups2: libcups2 conflicts with libcupsys2 (<< 1.3.7-6) libcupsys2 (version 1.3.7-1ubuntu3.5) is present and installed. dpkg: error processing libcups2_1.3.9-2ubuntu9.2_i386.deb (--install): conflicting packages - not installing libcups2 Errors were encountered while processing: libcups2_1.3.9-2ubuntu9.2_i386.deb brian@64studio:~/Desktop$ sudo dpkg -i --auto-deconfigure libcups2_1.3.9-2ubuntu9.2_i386.deb dpkg: considering removing libcupsys2 in favour of libcups2 ... dpkg: yes, will remove libcupsys2 in favour of libcups2. (Reading database ... 112884 files and directories currently installed.) Unpacking libcups2 (from libcups2_1.3.9-2ubuntu9.2_i386.deb) ... De-configuring cupsddk, to allow removal of libcupsys2 ... De-configuring samba, to allow removal of libcupsys2 ... * Stopping Samba daemons [ OK ] De-configuring kdelibs4c2a, to allow removal of libcupsys2 ... De-configuring cnijfilter-common, to allow removal of libcupsys2 ... De-configuring hpijs, to allow removal of libcupsys2 ... De-configuring libgnomeprint2.2-0, to allow removal of libcupsys2 ... De-configuring libgtk2.0-0, to allow removal of libcupsys2 ... De-configuring cupsys-bsd, to allow removal of libcupsys2 ... De-configuring libwine-print, to allow removal of libcupsys2 ... De-configuring hal-cups-utils, to allow removal of libcupsys2 ... De-configuring gnome-cups-manager, to allow removal of libcupsys2 ... De-configuring libgnomecups1.0-1, to allow removal of libcupsys2 ... De-configuring libgs8, to allow removal of libcupsys2 ... De-configuring cupsys-client, to allow removal of libcupsys2 ... De-configuring python-cups, to allow removal of libcupsys2 ... De-configuring scribus, to allow removal of libcupsys2 ... De-configuring cnijfilter-mp210series, to allow removal of libcupsys2 ... De-configuring cupsddk-drivers, to allow removal of libcupsys2 ... De-configuring cupsys, to allow removal of libcupsys2 ... * Stopping Common Unix Printing System: cupsd [ OK ] De-configuring libgnomecupsui1.0-1c2a, to allow removal of libcupsys2 ... De-configuring hplip, to allow removal of libcupsys2 ... De-configuring libcupsimage2, to allow removal of libcupsys2 ... Setting up libcups2 (1.3.9-2ubuntu9.2) ... dpkg: dependency problems prevent configuration of libcupsimage2: libcupsimage2 depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing libcupsimage2 (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of hplip: hplip depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing hplip (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libgnomecupsui1.0-1c2a: libgnomecupsui1.0-1c2a depends on libcupsys2 (>= 1.2.7); however: Package libcupsys2 is not installed. dpkg: error processing libgnomecupsui1.0-1c2a (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cupsys: cupsys depends on libcupsimage2 (>= 1.3.0); however: Package libcupsimage2 is not configured yet. cupsys depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing cupsys (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cupsddk-drivers: cupsddk-drivers depends on libcupsimage2 (>= 1.3.0); however: Package libcupsimage2 is not configured yet. cupsddk-drivers depends on libcupsys2 (>= 1.3.0); however: Package libcupsys2 is not installed. dpkg: error processing cupsddk-drivers (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cnijfilter-mp210series: cnijfilter-mp210series depends on libcupsys2 (>= 1.2.1); however: Package libcupsys2 is not installed. dpkg: error processing cnijfilter-mp210series (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of scribus: scribus depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing scribus (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of python-cups: python-cups depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing python-cups (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cupsys-client: cupsys-client depends on libcupsimage2 (>= 1.3.0); however: Package libcupsimage2 is not configured yet. cupsys-client depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing cupsys-client (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libgs8: libgs8 depends on libcupsimage2 (>= 1.3.0); however: Package libcupsimage2 is not configured yet. libgs8 depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing libgs8 (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libgnomecups1.0-1: libgnomecups1.0-1 depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing libgnomecups1.0-1 (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of gnome-cups-manager: gnome-cups-manager depends on libcupsys2 (>= 1.2.7); however: Package libcupsys2 is not installed. gnome-cups-manager depends on libgnomecups1.0-1 (>= 0.2.0); however: Package libgnomecups1.0-1 is not configured yet. gnome-cups-manager depends on libgnomecupsui1.0-1c2a (>= 0.31); however: Package libgnomecupsui1.0-1c2a is not configured yet. dpkg: error processing gnome-cups-manager (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of hal-cups-utils: hal-cups-utils depends on cupsys; however: Package cupsys is not configured yet. hal-cups-utils depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. hal-cups-utils depends on python-cups; however: Package python-cups is not configured yet. dpkg: error processing hal-cups-utils (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libwine-print: libwine-print depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing libwine-print (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cupsys-bsd: cupsys-bsd depends on cupsys-client (= 1.3.7-1ubuntu3.5); however: Package cupsys-client is not configured yet. cupsys-bsd depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing cupsys-bsd (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libgtk2.0-0: libgtk2.0-0 depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing libgtk2.0-0 (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libgnomeprint2.2-0: libgnomeprint2.2-0 depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. libgnomeprint2.2-0 depends on libgnomecups1.0-1 (>= 0.2.3); however: Package libgnomecups1.0-1 is not configured yet. dpkg: error processing libgnomeprint2.2-0 (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of hpijs: hpijs depends on hplip (>= 2.8.2-0ubuntu8.1); however: Package hplip is not configured yet. hpijs depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing hpijs (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cnijfilter-common: cnijfilter-common depends on libcupsys2 (>= 1.2.1); however: Package libcupsys2 is not installed. dpkg: error processing cnijfilter-common (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of kdelibs4c2a: kdelibs4c2a depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing kdelibs4c2a (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of samba: samba depends on libcupsys2 (>= 1.3.4); however: Package libcupsys2 is not installed. dpkg: error processing samba (--install): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cupsddk: cupsddk depends on libcupsys2 (>= 1.3.0); however: Package libcupsys2 is not installed. cupsddk depends on cupsddk-drivers; however: Package cupsddk-drivers is not configured yet. dpkg: error processing cupsddk (--install): dependency problems - leaving unconfigured Processing triggers for libc6 ... ldconfig deferred processing now taking place Errors were encountered while processing: libcupsimage2 hplip libgnomecupsui1.0-1c2a cupsys cupsddk-drivers cnijfilter-mp210series scribus python-cups cupsys-client libgs8 libgnomecups1.0-1 gnome-cups-manager hal-cups-utils libwine-print cupsys-bsd libgtk2.0-0 libgnomeprint2.2-0 hpijs cnijfilter-common kdelibs4c2a samba cupsddk brian@64studio:~/Desktop$ sudo dpkg -i libgtk2.0-0_2.14.4-0ubuntu1_i386.deb dpkg: considering removing libgail18 in favour of libgtk2.0-0 ... dpkg: no, cannot proceed with removal of libgail18 (--auto-deconfigure will help): libgtkhtml3.8-15 depends on libgail18 (>= 1.10.1) libgail18 is to be removed. dpkg: regarding libgtk2.0-0_2.14.4-0ubuntu1_i386.deb containing libgtk2.0-0: libgtk2.0-0 conflicts with libgail18 libgail18 (version 1.22.1-0ubuntu1) is present and installed. dpkg: error processing libgtk2.0-0_2.14.4-0ubuntu1_i386.deb (--install): conflicting packages - not installing libgtk2.0-0 Errors were encountered while processing: libgtk2.0-0_2.14.4-0ubuntu1_i386.deb brian@64studio:~/Desktop$ ~~~~

Tree

  • Quentin Harley
  • 05/24/07
  • Wed, 08/26/2009 - 06:07
Hi Kaimerra, You will have to ride the tree out... Try to backport only from intrepid, to limit the extra dependencies pulled in by those new packages. I am a bit swamped at the moment, but will attempt this as soon as I can get some breathing space again ;-) Cheers, Quentin

Tree Climbing

  • kaimerra
  • 11/14/08
  • Wed, 08/26/2009 - 13:59
I see, I will try to map out a backport path in the next couple days if I can. I will post what I find out. There are probaly more people here wanting to run the new Guitarix builds. :)