RME Digi 96/PAD and jackd related problems

  • stanlea
Posted: Sun, 08/26/2007 - 22:15
I always had problems using the ADAT channels of my RME. 64studio has the same problems that the other distros I have tried. But if it can help, I found a tricky trick : if I try to start jackd, I get an error message, and jack stops. After that, I launch Ardour, and in the Jack menu, I disconnect and reconnect Jack. Now I switch to the jackd interface and I start jack : all works fine, then I can even close Ardour and make what I want. What do you think of that ?

Finally I found the

  • stanlea
  • 08/21/07
  • Sat, 10/06/2007 - 21:54
Finally I found the solution. Very simple. When using ADAT, you have to enable ALL input and outputs in jack config, even if you do not use them. My mistake was to enable only output 1 and 2, for I just use these two...

Hammerfall HDSP 9652

  • david-0
  • 09/17/07
  • Mon, 09/17/2007 - 11:37
I'm having repeatable problems with my Hammerfall card- OctoPre combination. It seems that every time i reboot, ALSA had 'forgotten'about the HDSP card i've only just set up. I have to re point ALSA conf to the RME card, then, before switching the Octo-PRe on, run the HDSP mixer ( the task of displaying the ADAT i/0 seems to crash the mixer... still ). Is there a way to keep the alsaconf settings permanently? i'm running 64Studio ( debian ) on an AMD64. is there maybe a 64bit issue here? loving linux audio!

Alsaconf

  • Quentin Harley
  • 05/24/07
  • Mon, 09/17/2007 - 15:04
As I lamented on another topic, alsaconf has so far only caused problems for me. I generally install 64studio, and configure my cards as in User FAQ 10 to sort them out. My advice, try to do the same. Perhaps I am doing it wrong, but you can only hit your head so many times against a problem until permanent brain damage sets in! Cheers!

Thank you for your answer. I

  • stanlea
  • 08/21/07
  • Tue, 08/28/2007 - 20:43
Thank you for your answer. I guess too ! But actually, it works like that, and I can make music. Maybe there is something related with the Alsa driver of my card.

Settings

  • Quentin Harley
  • 05/24/07
  • Mon, 08/27/2007 - 06:50
It sounds to me that Ardour knows which settings to guess on your system, while it is not configured correctly in "Jack Control" I tried starting Ardour from terminal to see if it allows the jack sdout through, but alas! Anyones guess at this stage. Perhaps post your current settings in Jack control (every setting) or post a link to a screenshot to it.