MIDI not working on ALSA MODULAR SYNTH

  • lemule
Posted: Thu, 08/30/2007 - 06:22
Any and All, ALSA MODULAR SYNTH (AMS) cannot see my midi keyboard. I have tried to use the virtual keyboard as well with no luck. The overall is as follows. I am able to config a midi ( virtual or phsycal ) in jack control to ZynAddSubFx, amSynth, Rosegarden... and everything plays fine. Works as you would expect. When I config the midi for AMS in jack control window everything appears fine. I can connect the midi into the midi imput of the AMS. The problem is that I am not able to find the midi when I go into the AMS control centre. I see no midi device. I had this problem on version 1 of 64Studio and was one of the main reasons to upgrade. Am I missing something? I have a 2X64 AMD 3500 ( or something ) M-AUDIO 2496. Any help would be greatly appreciated. Lemule

Midi Controller

  • Quentin Harley
  • 05/24/07
  • Thu, 08/30/2007 - 19:49
I got myself a cheap USB midi controller after having problems with my creative Audigy card (which turned out to be defective), and the moment it is plugged in it worked - out of box! You just have to do the "multiple sound interfaces" trick - see my FAQ nr 9, http://64studio.com/faq_user Cheers,

RE: Tested

  • lemule
  • 08/30/07
  • Thu, 08/30/2007 - 16:16
Quentin, Thanx for the reply. The problem I have is not playing, its that the 'Control Center' does not see my midi controller ( virtual or external )so I cannot map any midi events to AMS. I am pretty sure that I configed the audio outs as well since I noticed that they do not map when opening AMS. I am able to play many of the demo's just not the ones that require a MIDI controller. I will look at the setup once I am home, however, I feel that your response does not help my current situation. Thanks anyway.. it does help to know that I am not alone. Lemule

Tested

  • Quentin Harley
  • 05/24/07
  • Thu, 08/30/2007 - 07:20
I played a bit with AMS after a previous post about it crashing. I could connect my vkbd to it in jack control, and play any of the demo modules I loaded into it. Just check that the audio channels are connected as well. AMS does not automatically select the outputs, as it is quite often used as a recording instrument into Rosegarden or Ardour. Hope that helps,