Can you have different versions of the same library??

  • johne53
Posted: Thu, 10/18/2007 - 16:40
64studio came pre-installed with wxWidgets 2.63. Unfortunately, one of the apps that I installed later required version 2.8. Synaptic (rightly or wrongly) uninstalled a few apps that apparently had wxWidgets 2.63 as a dependency. I didn't notice what they all were - but one of them was Audacity. Since I installed wxWidgets 2.8 I've tried to re-install Audacity - but Synaptic keeps telling me that this will re-install wxWidgets 2.63 (even though I'm already running 2.8). Should I go ahead with this? I don't want wxWidgets to be overwritten by an older version - but then again, I don't know what the ramifications are for having two different versions of the same library present. Any advice please?

Versions

  • Quentin Harley
  • 05/24/07
  • Sun, 10/21/2007 - 14:46
You have to make sure that the packages you install have been packaged for etch, or at least back ported for etch. That means is uses packages that are available in etch. When you start mixing the different Debian releases, you can start getting trouble, like above. Look for an etch version of that application, and all should be well. You'll then have to downgrade the widgets package again. If you feel this package should be included in 64studio, let Free know, and perhaps he could back port it for you to test in 64studio (if not available elsewhere) Search the net... you may be surprised at what you may find.