missing library in testing???

  • alex_step
Posted: Mon, 11/05/2007 - 23:24
I trying to install fst from 64studio testing for i386, but have trouble: it must have wine and wine-dev of the same version but repository have wine_0.9.47-1~bpo.1_i386.deb and wine-dev_0.9.47-1~etch1_i386.deb, and these imcompatible... How can I install fst???

potential solution?

  • ethanay
  • 05/20/08
  • Sun, 06/08/2008 - 10:22
dssi-vst compiled correctly with wine *-dev package available in the repositories, so maybe it is just a matter of changing the dependencies of FST to point toward that instead...?

wine in lenny

  • ethanay
  • 05/20/08
  • Sun, 06/08/2008 - 03:01
64studio 3.0 beta doesn't permit the install of wine 0.9.58 due to a missing libldap2 dependency. Satisfying the dependency would break 64studio. 1.0rc2 is missing the wine-dev package, so fst is out of the question unless you stay with 64studio 2.0. However, good news: I installed wine 1.0rc2 from the repos, then Encore (win notation program), and Pianoteq (win Piano modeling software with standalone and VST modes). after that, I installed dssi-vst 0.7.1 from source and wineasio from source (using checkinstall). Pianoteq is working wonderfully with dssi-vst in vstmode and works great standalone through wineasio. Wine has never run better, either! The interface is much less buggy. The VST plugin still suffers from a non-dynamic interface that doesn't update (e.g., volume meter...), but is stable and all the interactive controls are functional.

dssi-vst 0.7 is good to go

  • ethanay
  • 05/20/08
  • Mon, 05/26/2008 - 11:43
i have successfully used dssi-vst with Pianoteq 2.2 vst plugin form, wine 0.9.58 from winehq repos. compiled and installed using checkinstall 1.6 -- very useful tool, recommend including in future repositories. however, wineasio remains a mystery problem with pianoteq standalone (.exe), but i have posted to a new thread about this

you're right...

  • ethanay
  • 05/20/08
  • Mon, 05/26/2008 - 09:07
thanks for the replies i ran into the same problem with dssi-vst I downloaded the latest .deb's for wine directly from the site and installed. compiled wineasio 0.7.4 successfully into a .deb and installed (and ran regsvr32 wineasio.dll). pianoteq will run fine in wine, but wineasio simply does not appear as an option to select in the audio setup! i am at a loss, because i have received no errors at all during the entire process. i am uninstalling wine, etc and will try again using the wine repos -- will report back here if i can get something to work, or on a new thread if the issue remains unresolved

Sorry...

  • Quentin Harley
  • 05/24/07
  • Sun, 05/25/2008 - 19:26
I run the 64bit version and can not test this.

dssi-vst also needs wine-dev

  • Pablo
  • 07/11/07
  • Sun, 05/25/2008 - 13:05
Dssi-vst also needs wine-dev to be compiled. I second. I wish the team upgraded wine-dev. I've had to downgrade to wine 0.9.58 which is available in the wine repository for Debian Etch http://www.winehq.org/site/download-deb. Pablo

several months later...

  • ethanay
  • 05/20/08
  • Sun, 05/25/2008 - 09:26
I am experiencing a similar problem after upgrading to 2.1, and am surprised there isn't a post in response to this. Also, FST is impossible to install from repositories since it depends on wine-dev which did not make the 2.1rc upgrade, but I will be using dssi-vst anyway.