libc6 dependancy hell

  • glarbl_blarbl
Posted: Tue, 12/11/2007 - 06:34
I tried to upgrade my 64Studio 2.0 install using apt-get and ran into this error: You might want to run `apt-get -f install' to correct these. The following packages have unmet dependencies: libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch2) but 2.3.6.ds1-13 is installed libc6-i386: Depends: libc6 (= 2.3.6.ds1-13etch2) but 2.3.6.ds1-13 is installed E: Unmet dependencies. Try using -f. so I did: blackbox:~# apt-get -f install Reading package lists... Done Building dependency tree... Done Correcting dependencies... Done The following extra packages will be installed: libc6 Suggested packages: glibc-doc The following packages will be upgraded: libc6 1 upgraded, 0 newly installed, 0 to remove and 63 not upgraded. 2 not fully installed or removed. Need to get 0B/4130kB of archives. After unpacking 219kB disk space will be freed. Do you want to continue [Y/n]? (Reading database ... 102425 files and directories currently installed.) Preparing to replace libc6 2.3.6.ds1-13 (using .../libc6_2.3.6.ds1-13etch2_amd64.deb) ... Unpacking replacement libc6 ... dpkg: error processing /var/cache/apt/archives/libc6_2.3.6.ds1-13etch2_amd64.deb (--unpack): trying to overwrite `/usr/lib64', which is also in package ardour-gtk Errors were encountered while processing: /var/cache/apt/archives/libc6_2.3.6.ds1-13etch2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) I tried uninstalling the offending packages, but it didn't work. Nor did apt-get dist-upgrade. I'm at a loss here, any help would be greatly appreciated!

Solved, I guess

  • glarbl_blarbl
  • 06/15/07
  • Fri, 12/14/2007 - 09:49
I commented out the debian repositories, now libc6 is happy being plain old dsl-13.. Not that big a deal I guess, since I don't really use anything only available there.. Guess I'll have to download and install BOINC manually :P