Can't find 2.1? testing repository enabled...

  • ixemul
Posted: Sat, 01/05/2008 - 16:28
Hello, I read the VST/VSTi guide and some of the posts here about upgrading to 2.1 and I must confess, I'm stumped. I've enabled the testing repository, I've disabled all other repositories, run the upgrade a number of times and I'm still showing 2.0 on the 64studio "dummy" package, and I can't find wineasio in the repository... Not sure what to do next, I've searched the forum, looked at the scripts, and read all the man pages I could think of. Any suggestions? Thanks!

Ad hoc repository

  • Quentin Harley
  • 05/24/07
  • Sun, 01/06/2008 - 10:03
If you have installed and deinstalled, the packages might be in yout apt-cache /var/cache/apt/archives copy all the .deb file into a now repository folder in your home directory, in this example my-repository now, in a terminal window, do the following. $ cd my-repository $ dpkg-scanpackages ./ /dev/null | gzip -9c > ./Packages.gz This creates a ad-hoc repository of all the packages you installed on your system after installation. Old and New. Add the new repository to your sources.list deb file:/home//my-repository/ ./ After apt-get update Your old de-installed packages should now be installable again. I use this when I help to install new systems. You can then set up a system without having to download anything from the web (given it is the same architecture)

Glad to hear that

  • Pablo
  • 07/11/07
  • Sat, 01/05/2008 - 21:48
I run a VST plugin for the guitar. It used to work. Don't ask why, I unnstalled wine and wineasio. And I'd like to have it again. I am looking forward to the new release. Thanx Quentin and the 64studio team! Have a happy year. Pablo

Testing

  • Quentin Harley
  • 05/24/07
  • Sat, 01/05/2008 - 16:40
I have noticed the same while helping to set up a new system last week. I believe it is because the guys are gearing up for the next 64studio release, and that they are perhaps finalising the next stable release. Testing might be in limbo for the time being. Hopefully for not too long. The system I set up last week is very functional though - better than mine at the moment, but I suspect better graphics hardware might be the ticket...

testing

  • ixemul
  • 01/05/08
  • Sat, 01/05/2008 - 16:53
Yes, I have no complaints; I did have to install new nVidia drivers before X would work properly, but that's not a big deal. It's a great distro, just wanted to make my VSTs work ;-) Thanks for the reply - To the maintainers - anxiously awaiting the release!!