Audacity upgrade

  • mirami
Posted: Sun, 03/09/2008 - 13:24
Hello everybody, I just tried upgrade Audacity aplication and I found that upgrade is dependent on others packages. audacity: Depends: libgtk2.0-0 (>=2.12.0) but 2.10.13-1~bpo.1 is to be installed Depends: libwxbase2.6-0 (>=2.6.3.2.2) but 2.6.3.2.1.5 is to be installed Depends: libwxgtk2.6-0 (>=2.6.3.2.2) but 2.6.3.2.1.5 is to be installed I have checked all repositories from debian (etch, etch/updates, etch-backports and even sid) and both repos from 64studio stable and testing. But I can't find dependent packages. It is normal or I doing something wrong??? Can I get these packages from others repositories??? Btw for what kind of packages is etch-backports repo??? Thanks for advices mirami Asus M6Va,CPU 2GHz, RAM 2GB, 64studio 32bit 2.1 pre11

Thanks

  • mirami
  • 02/20/08
  • Mon, 03/10/2008 - 14:53
Thanks Pablo and Quentin, Packages are not in backports repo, but at least now I understand for what this repository is. It's not bad :-) mirami Asus M6Va,CPU 2GHz, RAM 2GB, 64studio 32bit 2.1 pre11

Dependencies

  • Quentin Harley
  • 05/24/07
  • Mon, 03/10/2008 - 05:24
Did you try the 64studio etch-backports repository? deb http://apt.64studio.com/backports etch-backports main Free keeps quite a lot of extra packages here, and it might be a good idea to try it. Just be sure to have it disabled when you do the initial upgrade, as it might introduce things not intended... But this might just be me being paranoid :-) Hope it works!

Same problem here

  • Pablo
  • 07/11/07
  • Sun, 03/09/2008 - 21:41
That's why they call it testing, isn't it? I cannot upgrade Audacity either. Unresolved dependencies. Is it worth it, anyway? I don't use it very much but it runs fine for me. My two cents Miriam: stick to Debian etch (Debian stable) (BTW: sid=Debian unstable lenny= Debian testing). As Quentin has already explained here, 64studio, even the testing branch, is based on Debian stable. Only resort to sid or lenny (or possibly other debian based repositories) if you know what you are doing or adviced to do so. If you enable sid you risk messing up your system. I found this: http://www.backports.org/dokuwiki/doku.php Cheers! Pablo