repositories

  • starspace
Posted: Wed, 06/27/2007 - 17:40
hi i just need to find some repositories that does work with synaptic, i beacause i need some tango fonts and icons and python language to install automatix2 and i dont have repositories to do that because the original ones are very short in packages. can people help me out there and inform me of good repositories that work with 64studio?

Devian Etch and 64 Studio Stable Repositories

  • scribe63
  • 09/13/07
  • Thu, 01/24/2008 - 15:30
The User FAQ states that Debian Etch and 64Studio main repositories are compatible, but in some instances they are not. 1. Issue nvidia-kernel-source, nvidia-glx, nvidia-kernel-source, nvidia-kernel-2.6.18-5-686 for etch and nvidia-glx, nvidia-kernel-2.6.21-1-multimedia-486 64studio are different and conflicting versions. It works for debian etch because the nvidia-kernel-source, nvidia-glx, nvidia-kernel-source, nvidia-kernel-2.6.18-5-686 are of the same versions. It does not work for 64Studio because there is no nvidia-kernel-source to match nvidia-kernel-2.6.21-1-multimedia-486 version. With nvidia-glx there is only one of either of the two different version available to install. It's either the debian etch version (nvidia-glx-1.0.8776-4) or the 64Studio version (nvidia-glx-1.0.9755-1~bpo.1), not both. So therefore no graphics acceleration for 64 Studio or vice versa. 2. Issue with xine, totem backends, and gnome debug applications. After initially using the applications from both etch and 64Studio repositories. I ran into the issue with nvidia-glx and decided to disable the 64Studio repository. Totem and Xine worked fine, but after codecs updates from etch, they started crashing. When totem crashed bug buddy would pop up, and i attempted to submit a full bug report manually. When i tried to install gnome-dbg metapackage, i ran into this issue, gnome-dbg: Depends: libgtk2.0-0-dbg but it is not going to be installed Depends: libgnomeui-0-dbg but it is not going to be installed Depends: libgstreamer0.10-0-dbg but it is not going to be installed Debian Etch: ibgtk2.0-0-dbg version 2.8.20-7 libgnomeui-0-dbg version 2.14.1-2 libgstreamer0.10-0-dbg version 0.10.10.13 64Studio: libgtk2.0-0-dbg version 2.10.12-1~bpo.1 libgnomeui-0-dbg version 2.12.18.2~bpo.1 libgstreamer0.10-0-dbg version 0.10.12-4~bpo.1 Same thing here again, the debian etch and the 64Studio versions are different and conflicting so the installation fails. At this point it seems safe to assume this probably the reason why my vmware-server installation stopped working also. It seems the moral of the story is mixing of repositories is a NO NO and should not be stated as such or taken with a grain of salt, things eventually do get broken. It seems like you have to stick with one repos or the other, not both at the same time unles version, updates, etc... properly match. jawara

Repositories

  • Quentin Harley
  • 05/24/07
  • Wed, 06/27/2007 - 22:34
64Studio is Debian Etch (Stable) based. Any debian repositories that are Etch based should work (given the packages are stable) If you feel adventurous, you could dip into testing, unstable etc. (Own risk though). Cheers