azr3-jack & gtkmm-2.4 dependencies

  • pianoman
Posted: Sun, 06/08/2008 - 21:57
azr3-jack (hammond organ simulator) depends on gtkmm-2.4 >version 2.8. When I try to install the dev version, i.e., libgtkmm-2.4-dev, I get dependency errors. Tried switching on and off the repos, to no avail. I did install the non-dev version ok, but azr2-jack doesn't find it, and I assumed it needed the -dev version. Any suggestions? Gary

AZR3 on 64 Studio Solved

  • guitard00d
  • 10/15/07
  • Sat, 01/10/2009 - 19:34
Problem with AZR3 compiling on 64 Studio is this...First of all, lash-dev should have a hard dependency on libasound2-dev but it does not in 64 Studio. You have to manually install the libasound2-dev package. Secondly, you have to make sure that you have the g++ package installed. Just installing the required dev packages only installs g++ 3.3, you need g++ 4.1 installed or the program won't even begin to compile. That's all there is to it, and it compiles just fine.

I got it to compile, but...

  • guitard00d
  • 10/15/07
  • Thu, 12/11/2008 - 08:11
I got it to compile, but every time I try to run it I get this: lash_open_socket: could not connect to host 'localhost', service '14541' lash_comm_connect_to_server: could not create server connection lash_init: could not connect to server 'localhost' - disabling LASH Could not initialise LASH! Jack is running. Why the program is trying to connect to port 14541 makes no sense to me unless that's a port that Jack listens on. But I can nmap localhost and that port isn't listed at all. Kinda sad, Beatrix is a damn good Hammond emulator, but has no GUI, no support for Jack, and does not have any implementation for a sustain/hold pedal through MIDI. Bristol, I'm sorry to say, is the worst Hammond simulation I've ever heard and seriously needs documentation. Maybe the other synth models will come in handy someday, but for now, v0.30 is so poor sounding that it's useless. Nice eye candy, but that's it, and eye candy doesn't sound worth a damn on stage or on a recording. So, I was really hoping this program would work. No way I'm buying a Native Instruments Hammond emulator, I don't run Linux so I can run Windows programs.

Lash

  • Quentin Harley
  • 05/24/07
  • Tue, 06/10/2008 - 05:50
You need the Lash-dev file, if I am not mistaken...

Appears that pianoman's

  • guitard00d
  • 10/15/07
  • Sat, 01/10/2009 - 09:37
Appears that pianoman's issue is directly related to the x64 distro, not the x86 distro. Trying to compile Azr3-Jack on the x64 distro always barfs out this error about you not having the latest Lash-Dev package installed. When in fact, the version that's installed is actually one version newer than the program's minimum requirements. Why this is happening and how to get around it are both beyond me. Seems the more I mess with x64 Linux stuff, the more oddities I find that send me running back to x86.

-dev packages, sources, apt-pinnig?

  • the C.L.A.
  • 06/09/08
  • Mon, 06/09/2008 - 15:59
Hi. I installed 2.1 a few days ago (after I tried Fedora + CCRMA for a while and found it too cutting edge for my needs). I also needed some -dev packages (for compiling an own version of ardour and japa - wich BTW I think should be included in 64Studio as it currently lacks a capable analyser. ;) ). I finally enabled the etch-backports but wondered why the -dev packages are not included in the default repo. Installing the needed packages pulled in an unwanted upgrade and fiddling around I finally messed up some things, so I think I better reinstall. But before doing this it would be good to have some suggestions wich sources should be enabled and if there is some advice for apt-pinning and possibly additional apt.conf settings to avoid unwanted side effects. My idea is to stay with stable 64Studio, have all the -dev packages and sources for stable available, receiving security updates, being able to install additional packages from etch and do handselected updates from 64Studios etch-backports. Advice would be highly appreciated. Axel. ^.^

etch-backports repository?

  • Quentin Harley
  • 05/24/07
  • Mon, 06/09/2008 - 05:58
Some of the dev files are hiding in there...

-dev files

  • pianoman
  • 06/07/08
  • Mon, 06/09/2008 - 20:48
Thanks for your reply. I looked in the backports repo and couldn't find any of the affected files. Here's a synopsis of what's happening. Repos enabled=stable, testing, for etch, studio64 * Synaptic search yield libgtkmm-2.4-dev latest ver 1:2.8.8-1 * Mark for install yields libsigc++-2.0-dev to be installed * Unresolvable dependency error: libgtkmm-2.4-dev: Depends: libglibmm-2.4-dev but it is not going to be installed So I tried to load the libglibmm-2.4 libglibmm-2.4-dev: Depends: libglibmm-2.4-1c2a (=2.12.0-1) but 2.12.9-0.1~bpo.1 is to be installed Any further suggestions would be appreciated? Gary

solved - libgtkmm-2.4-dev, but now lash lingers

  • pianoman
  • 06/07/08
  • Mon, 06/09/2008 - 21:52
I upgraded to Studio 64 v 2.1. No change. Then I found the backports listed in the synaptics repo list and voila. Don't know why I couldn't find it the first time. Now, however, when I run 'make' I get *** You don't have lash-1.0>=0.5.3, which you need in order to build this software. I do have lashd ver 0.5.4-1 installed. Gary