Rosegarden audio

  • cinder
Posted: Mon, 10/20/2008 - 07:20
I can't get any live audio into Rosegarden. It plays audio files. MIDI is funtional. The synth plugins work. I can use and hear every thing, except hear any or see any signal that is routed to it's inputs. Jack, Hydrogen, Ardour, Audacity, Qsampler, Qsynth... it all works... except Rosegarden. I'm running 64studio 2.1 on intel x86 with an Audiophile2496. Any ideas?

What message do you get?

  • Icemouse
  • 08/04/07
  • Thu, 10/23/2008 - 11:38
Do you have permission to write to the chosen path? If the path is fine, Rosegarden only asks you after pushing the virtual red LED for the first time.

Sorry! I forgot!

  • cinder
  • 10/20/08
  • Wed, 02/04/2009 - 04:19
I just wnted to say sorry for not responding. I forgot all about this post. I have since re-installed, and I can record audio in Rosegareden now. I don't know what the problem was, but Iv'e lost interest in Rosegarden anyway. Thanx for your support though. Timing is Everything!

Three more ideas

  • Pablo
  • 07/11/07
  • Mon, 10/20/2008 - 21:18
- Set the audio path In Rosegarden you have to set a path (which you have write permission) for the recorded audio files. I think the default path is /home/user/Rosegarden, but it doesn't exist if you haven't created first. It's much better if you have a different audio path for each project. You can see this configuration in Composition -> Edit Document properties -> Audio. - Set the track as an audio track Needless to say, the track has to be audio. By default, the tracks you add are assigned to a "General MIDI device". You have to choose audio by left clicking on the track. - Check the audio mixer I hope this helps Pablo

Rosegarden Audio

  • cinder
  • 10/20/08
  • Thu, 10/23/2008 - 08:07
Thanks for your reply's. Everything is enabled/armed/routed etc, but I have had a problem setting the audio file path. It won't set it. When I enable an audio track for record, I'm prompted to set the file path, so do, but when try to arm the track again, again I am asked to set the path again. Is it not possible to monitor a signal without setting the file path? This looks to me to have something to do with it

We need more information

  • Icemouse
  • 08/04/07
  • Mon, 10/20/2008 - 09:31
- You might has forgotten to enable 'Record on this track', by pushing the red virtual LED. - Rosegarden is broken for some hardware.