ArdourVST and Lenny

  • Killes
Posted: Tue, 11/04/2008 - 18:00
Hi, Im running 64studio lenny "beta" so as to have latest FFADO for my Saphire Pro. In the process of updating to lenny I somehow lost Ardour, nevermind, perfect occasion to install latest Ardour 2.6.1. Im using synaptic to install all dependencies not feeling like compiling too much stuff myself in fearo f breakign the install whih is running nicely otherwise - and I cant seem to get a wine-dev package compatible with the currently installed wine 1.1.5 ? Any idea where I could find corresponding wine-dev package or some other method to get ArdourVST compiled on the lenny 64studio? Cheers :) Killes running Asus F3Jv Laptop with Saphire Pro 26i/o

Yep, doh! :) wine-dev

  • Killes
  • 11/04/08
  • Tue, 11/25/2008 - 13:49
Yep, doh! :) wine-dev libwine-dev same same.

Wine-dev?

  • Quentin Harley
  • 05/24/07
  • Sun, 11/09/2008 - 17:40
Don't you need libwine-dev? Just asking...

Thanks indeed, but still no

  • Killes
  • 11/04/08
  • Sun, 11/09/2008 - 12:57
Thanks indeed, but still no wine-dev 1.1.5 which is what I really need, im giving up for now and installing without VST support until wine-dev 1.1.5 actually exists, too much hassle, no time. Conclusion it is not possible to compile ardourvst running latest wine and wineasio on 64 studio Lenny for now. Of course I'd love to be proved wrong :)

64 Studio 3.0 pre ..

  • Quentin Harley
  • 05/24/07
  • Thu, 11/06/2008 - 19:56
For the lenny based 64 Studio, check the 64studio lenny-backports repository. Wine 1.1.5 is available here... Cheers, Q

Hah, if you actually browse

  • Killes
  • 11/04/08
  • Wed, 11/05/2008 - 20:56
Hah, if you actually browse the repo I see there is no Lenny section under /apt/dists/ even though there is a lenny.list in /apt/sources.list.d Ive also tried downgrading wine to 1.1.1 as suggested in http://www.64studio.com/node/779 but then I cant find libwine-jack; libwine-alsa etc version 1.1.1... Would compiling ardourVST with just wine 1.1.1 and wine-dev 1.1.1 then upgrading all back to 1.1.5 work ? I'll try tomorrow when I have some more time and keep posted incase someone comes across the same snafu.

Thanks, I forgot to mention

  • Killes
  • 11/04/08
  • Wed, 11/05/2008 - 17:37
Thanks, I forgot to mention I tried that repository and it does not work in synaptic, the etch one does but with the lenny one i get the message : Could not download all repository indexes The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct. http://wine.budgetdedicated.com/apt/dists/lenny/main/binary-i386/Packages.gz: 404 Not Found [IP: 81.171.111.184 80] .....seems odd to me an official repository wouldnt work, all other repositories are fine for me. I haven't tried it with anything else than synaptic though.

wine

  • Quentin Harley
  • 05/24/07
  • Tue, 11/04/2008 - 18:33
The latest wine packages for lenny are always available on : deb http://wine.budgetdedicated.com/apt lenny main Cheers,