AR928X Atheros wireless not recognized after install

  • angelsguitar
Posted: Wed, 11/26/2008 - 18:26
Hi. I recently bought a new laptop, which has one of the newer Atheros network interfaces. As reported after running lspci: Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01) Seems it's not detected in 64Studio 2.1 during install. How do I get it working? I know madwifi drivers are supposed to work with most Atheros chipsets... Or should I go with ndiswrapper?

Worst timing...

  • Quentin Harley
  • 05/24/07
  • Wed, 11/26/2008 - 19:23
Makes me think of my own experience. When I started (trying) to use 64 Studio, Etch was not released yet, and we were going through the same. My hardware was too new, and I had to wait for the etch release before everything was supported. Out problem is that the kernel needs to be recompiled under lenny sources before we can support 3rd party drivers in lenny, and the etch drivers are too old. Catch 22. We always experience a bit of turmoil for users of latest hardware around this time but it gets sorted in the end. Be patient ;-)

Patience is a virtue...

  • angelsguitar
  • 12/22/07
  • Fri, 12/05/2008 - 12:58
Well, seems I'll have to wait. The driver I need is ath9k (http://wireless.kernel.org/en/users/Drivers/ath9k) and I believe it's not that simple to install on kernels older than 2.6.26 . Quoted from http://wireless.kernel.org/en/users/Download : // Known issues * ath9k on older kernels ath9k is currently only enabled on kernels >= 2.6.26. If a developer is interested in older kernels they'll have to add compatibility support for it. //