using dssi-vst

  • dadaprod
Posted: Sat, 12/06/2008 - 18:08
I switch recently on the 32bits version of 64studio, I am tring to install dssi-vst. I first have tried (from synapctic) to install "dssi-dev", then I have : dssi-dev: Dépend : libjack0.100.0-dev but not install then I try to install : libjack0.100.0-dev: Dépend : libjack0.100.0-0 (=0.101.1-2) but 0.103.0-6~etch1 must be installed but "libjack0.100.0-0" is already installed.. is there a dssi-vst . deb somewhere ?

export VST_PATH

  • dadaprod
  • 05/22/08
  • Wed, 12/31/2008 - 16:57
I have defined the VST_PATH variable by adding the following line : export VST_PATH= votreDossierVST in the .bashrc in my home directory Anyone else have some tips?

VST

  • Quentin Harley
  • 05/24/07
  • Fri, 12/19/2008 - 06:34
I do not use VST's, partly because I run the 64bit version that prevented me to do that in the past, and because I have no need for them (yet) Anyone else have some tips?

dssi-vst in Rosegarden and Jack rack

  • dadaprod
  • 05/22/08
  • Thu, 12/18/2008 - 20:38
now I can launch my vst mi the command vsthost myplugin-vst.dll, but I still can't do if from rosegarden or jack rack.. I used, this setup in the Makefile : DSSIDIR = /usr/lib/dssi LADSPADIR = /usr/lib/ladspa so I can find the file dssi-vst.so, in /usr/lib/dssi and /usr/lib/ladspa.. But in jack rack, In only see the ladsap plugins that wera already accessible, no vst plugins..

VST_PATH variable

  • Tomahawk
  • 12/29/08
  • Mon, 12/29/2008 - 20:10
You need to set the VST_PATH environment variable to your folder with the vst plugins you want to enable. ************************************** Tomahawk "The Father of Gangsta Swing" http://myspace.com/vikingtomahawk

I found it at the end

  • dadaprod
  • 05/22/08
  • Tue, 12/16/2008 - 20:01
I found it at the end (Ubuntu forums) : you need to install this : sudo apt-get install libasound2-dev

make error

  • dadaprod
  • 05/22/08
  • Sun, 12/07/2008 - 10:40
that's right, the repository was missing, now I am trying the compilation of dssi-vst, and I think i have some header files that are missing... how do we get the "seq_event.h" ? cheers, here is the prompt : --- $ make g++ -shared -Wl,-Bsymbolic -g3 -Ivestige -Wall -fPIC -o dssi-vst.so dssi-vst.cpp remotevstclient.o -L. -lremoteplugin -lasound In file included from dssi-vst.cpp:12: /usr/include/dssi.h:28:28: error: alsa/seq_event.h: Aucun fichier ou répertoire de ce type dssi-vst.cpp:14:33: error: alsa/seq_midi_event.h: Aucun fichier ou répertoire de ce type /usr/include/dssi.h:307: error: ‘snd_seq_event_t’ has not been declared /usr/include/dssi.h:321: error: ‘snd_seq_event_t’ has not been declared /usr/include/dssi.h:359: error: ‘snd_seq_event_t’ has not been declared /usr/include/dssi.h:375: error: ‘snd_seq_event_t’ has not been declared dssi-vst.cpp:50: error: ‘snd_seq_event_t’ has not been declared dssi-vst.cpp:76: error: ISO C++ forbids declaration of ‘snd_midi_event_t’ with no type dssi-vst.cpp:76: error: expected ‘;’ before ‘*’ token dssi-vst.cpp:119: error: ‘snd_seq_event_t’ has not been declared dssi-vst.cpp: In constructor ‘DSSIVSTPluginInstance::DSSIVSTPluginInstance(std::string, long unsigned int)’: dssi-vst.cpp:178: error: ‘m_alsaDecoder’ was not declared in this scope dssi-vst.cpp:178: error: ‘snd_midi_event_new’ was not declared in this scope dssi-vst.cpp:184: error: ‘snd_midi_event_no_status’ was not declared in this scope dssi-vst.cpp: In destructor ‘virtual DSSIVSTPluginInstance::~DSSIVSTPluginInstance()’: dssi-vst.cpp:230: error: ‘m_alsaDecoder’ was not declared in this scope dssi-vst.cpp:231: error: ‘snd_midi_event_free’ was not declared in this scope dssi-vst.cpp: At global scope: dssi-vst.cpp:370: error: ‘snd_seq_event_t’ has not been declared dssi-vst.cpp: In member function ‘void DSSIVSTPluginInstance::runSynth(long unsigned int, int*, long unsigned int)’: dssi-vst.cpp:375: error: ‘m_alsaDecoder’ was not declared in this scope dssi-vst.cpp:382: error: ‘snd_seq_event_t’ was not declared in this scope dssi-vst.cpp:382: error: ‘ev’ was not declared in this scope dssi-vst.cpp:395: error: ‘snd_midi_event_decode’ was not declared in this scope dssi-vst.cpp: At global scope: dssi-vst.cpp:679: error: ‘snd_seq_event_t’ has not been declared make: *** [dssi-vst.so] Erreur 1

respositories

  • Quentin Harley
  • 05/24/07
  • Sat, 12/06/2008 - 21:30
Make sure you have the 64 Studio etch-backports repository enabled, and try again.