Firefox 3.0 - pango crash???

  • SEO Honolulu
Posted: Sat, 01/17/2009 - 03:29
Downloaded the newest firefox. Untarred into my home directory. Call it from console and here's what I get; matt@64studio:~/localapps/firefox$ ./firefox /usr/share/themes/Industrial/gtk-2.0/gtkrc:38: error: unexpected character `@', expected string constant (firefox-bin:3727): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory (firefox-bin:3727): Pango-WARNING **: No builtin or dynamically loaded modules were found. Pango will not work correctly. This probably means there was an error in the creation of: '/etc/pango/pango.modules' You should create this file by running pango-querymodules. (firefox-bin:3727): Pango-WARNING **: pango_shape called with bad font, expect ugly output (firefox-bin:3727): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output (firefox-bin:3727): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory (firefox-bin:3727): Gtk-WARNING **: Error loading theme icon for stock: Couldn't recognize the image file format for file '/usr/share/icons/gnome/32x32/status/gtk-dialog-error.png' (firefox-bin:3727): Pango-WARNING **: pango_font_get_font_map called with bad font, expect ugly output (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-WARNING **: _pango_cairo_font_install called with bad font, expect ugly output (firefox-bin:3727): Pango-WARNING **: pango_font_get_metrics called with bad font, expect ugly output (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory (firefox-bin:3727): Gtk-WARNING **: Error loading theme icon for stock: Couldn't recognize the image file format for file '/usr/share/icons/gnome/32x32/status/gtk-dialog-error.png' (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed (firefox-bin:3727): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)' failed Any suggestions? What debian repo you guys use to get newer apps?

Swiftfox

  • mick.ca
  • 05/23/07
  • Sat, 01/31/2009 - 16:55
swiftfox is noted for having removed and/or disabled the Pango fonts. for speed and performance. plus it's amazingly faster than firefox. MiCK

64studio-skel

  • skullnotions
  • 09/29/07
  • Sat, 01/17/2009 - 08:02
I think Iceweasel is integrated into the 64studio packages which keep the system stable for audio production, so sometimes you have to forgo the newer packages for system performance and stability. You can check the 64studio packages configuration by opening synaptic browsing to the packages, e.g. 64studio-skel, right click and select properties, and check out the entries in the Installed Files Tab. On 2.1 use 64studio/testing, add the src if needed, and use the 64studio/etch backports for development packages. Checkout the user/developer FAQ's, Tutorials & Manual. The user/development mailing lists are also worth joining. Cheers! dave